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Weighsoft Error: "The Invoice Number Has Already Been Used" When Posting to Financials

This article steps to resolve the above error message when posting invoices to Financials

Noel Collings avatar
Written by Noel Collings
Updated over 3 months ago

Overview

This error typically occurs when a previous posting run from Weighsoft to Financials has failed part-way through. It indicates that an invoice is being resent to Financials, even though it was already successfully transferred during a prior attempt.


Root Cause

When a posting run is initiated in Weighsoft:

  • Invoices are sent to Financials.

  • At the end of the run, those invoices are marked as posted in Weighsoft to prevent duplication in future runs.

However, if the posting run fails before completion:

  • Invoices processed before the failure are still sent to Financials.

  • These invoices are not marked as posted in Weighsoft due to the incomplete run.

As a result, when another posting run is attempted:

  • The same invoices are picked up again.

  • Financials rejects them with the error: "The Invoice Number has already been used."


Resolution

Recommended Fix

Upgrade to Weighsoft version 5.530.11 or higher, which includes a fix for this issue.

If you're experiencing this error, please contact Weighsoft Support to arrange an upgrade.

Manual Workaround

If an upgrade is not immediately possible, you can manually resolve the issue by:

  1. Identifying the affected invoice(s) that already exist in Financials.

  2. Marking them as posted in Weighsoft.

Refer to the article: β€œChange the Posting State of an Invoice” for step-by-step instructions on how to do this

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