Overview
The Waste Return report populates the D&R code based on finding a match for a ticket in the Waste Activity screen found in Administration>Lookups.
First of all the report will look at the transaction and get the EWC Code, Outlet and Address details.
It will then refer to the Waste Activity screen in an attempt to find a match.
if it is unable to find a match then it will run the check again, but without the Address details (just using the EWC Code and the Outlet).
If no match is found (or a match is found but there is no "Operation Code" in place) then the ticket will be logged as an exception.
Example 1
Ticket 74852 is set against address 4256, EWC code 15 01 01 and Outlet ACMEWO.
The system searches the Waste Activities screen but finds nothing with that address in place
The system then searches again without the address but still finds no match using the outlet and EWC code
This will result in an exception for that ticket as there is no code to pull through
Example 2
Ticket 73887 is set against address 4051, EWC Code 15 01 01 and outlet ACMEWI.
The system searches the Waste Activities screen but finds nothing with that address in place
The system then tries again and finds a match based on the EWC Code and the Outlet code
It finds a match but that line is missing an Operation Code
This will result in an exception for that ticket as the line that matches the EWC Code and Outlet has no Operation Code to pull through
Cause
An entry with D&R code is generated by the system when an outlet is edited and an EWC Code set against it.
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Solution
In order to resolve the exception you will need to provide an entry in the Waste Activities screen that matches at least the EWC Code and the Outlet for the ticket in question, and also has a linked Operation Code in place.
Once an entry exists the report can be re-run and that ticket will no longer come up as an exception.
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Alternatively, removing the EWC Code link from the Outlet will delete the entry in the Waste Activities screen.
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Note: The system will search through the Waste Activity screen from top to bottom until it finds a match. This means that creating a working entry will still not work if a broken entry still exists further up the list. The solution is to either amend a broken entry so it work, or create a new one and delete the original broken one.


